INCLUDE_DATA

Posts Tagged ‘TR-707’

Roland TR-707 test run

Tags: ,

13

03 2009

It’s Alive!

The TR-707 is finally assembled and tested. I cleaned all the working parts and gave the knobs a good clean with soapy water and some toohbrushing. They came up nice and clean. I also made a point of cleaning the switch membranes and the switch contacts. It’s quite amazing how much carbon builds up over the years. Just look at the colour of the tip of the cotton bud. I used a little contact glue to reattach the fader RF shield (I had to remove that since I wanted to give the case a good scrub under the tap) Once everything was back in place I had to re-solder the battery terminals. You have to un-solder them to detach the bottom of the case. With that done, it was time to test all the features to make sure everything worked. It’s alive! You can see a short demonstration of it in the video.

Tags: ,

13

03 2009

Hey that’s not analog!

Well the SH-3 repair and cleaning worked out just fine, and the lovely machine has now returned to the studio. Since I was in fixing mode it seemed like a good idea to take a look at the TR-707 that was sitting in it’s box on the shelf. TR-707? What? That’s not analog..!?!!? I know, I know, we actually plan to sell it since there’s still a demand for these boxes. They were used in the early days of Chicago house and while they are pcm based they still have a desirable sound.

The repair was quite simple, the cause of the problem was two fold. The power jack had some corrosion on it that was causing intermittent power. The previous owner had obviously been wiggling the power jack to get it to work and had eventually broken the solder traces. A simple fix of cleaning the jack and resoldering the pads fixed it. I’m now in the process of giving it a good clean before reassembling it. Once that’s done I’ll give it a good test run of all its features before we put it up for sale.

Tags: , ,

12

03 2009


Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0 Fatal error: Unknown: Failed opening required 'google_verify.php' (include_path='.:/usr/local/lsws/lsphp56/share/pear/') in Unknown on line 0